Sunday, November 6, 2016

Troubleshooting the Interception Driver installation

So, you are here because you've installed the driver and followed the directions, but for some reason your settings in the GUI don't seem to take effect.  Hopefully this can help.

This is caused when the dependencies didn't install correctly. If you run interaccel.exe directly, does it immediately open and close? If it's working right, it should stay open and look something like this:



If it stays open, it's actually working correctly, and you may not have changed any settings that affect anything (sensitivity is just a scalar for coming from QuakeLive - it doesn't affect anything you'd feel without acceleration turned on.  Try changing the post-scale numbers around instead).

So, if interaccel.exe closed immediately, you will want to make sure that you have the correct MS Visual C++ Redistributable installed, and then after that it's all about making sure the driver_install.bat actually ran correctly. There are a few things that can block it from working:

  1. Sometimes Windows isn't actually running it as admin from the batch file. You can try to run a command prompt as admin by typing "cmd" in the start search bar and right clicking the program then running it as admin.  From there, use the "cd" command to change to the directory with driver_install.bat, and run it directly like that.
  2. Some antivirus products have been known to sandbox the installer, which results in the installer thinking it worked correctly, but it actually didn't get to write the files to the Windows directory. Turn off AV for a minute, run the installer, and turn AV back on.
  3. And sometimes, Windows just gets into a really weird state where it doesn't let the installer do its thing. A simple reboot and try again has fixed it way too many times.
And don't forget to reboot once the installer runs.